import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\S\\n]*([A-Z][^a-z]*)((?:\\n(?![^\\S\\n]*[A-Z][^a-z\\n]*$).*)*)$";
final String string = " PROCURADORIA GERAL DO ESTADO\n\n"
+ " PROCURADORIA DE SERVIÇOS DE SAÚDE\n\n"
+ "EXMO. SR. DR. JUIZ DE DIREITO DO CARTÓRIO ÚNICO DOS JUIZADOS\n"
+ "ESPECIAIS DA FAZENDA PÚBLICA DA COMARCA DE XPTO DO\n"
+ "ESTADO DO RIO DE JANEIRO\n\n"
+ "Processo nº: 123456789\n\n"
+ " Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Tellus id interdum velit laoreet. Sapien faucibus et molestie ac feugiat sed lectus vestibulum. Suscipit adipiscing bibendum est ultricies integer quis auctor. Egestas fringilla phasellus faucibus scelerisque eleifend donec. Pharetra pharetra massa massa ultricies mi. Urna nunc id cursus metus aliquam. Faucibus a pellentesque sit amet porttitor eget dolor morbi non. Sapien pellentesque habitant morbi tristique senectus et netus. Tincidunt dui ut ornare lectus sit amet est placerat in. Est velit egestas dui id ornare. Dignissim enim sit amet venenatis urna cursus eget. Pellentesque habitant morbi tristique senectus et netus et malesuada. Orci dapibus ultrices in iaculis nunc sed augue lacus. Eu facilisis sed odio morbi quis commodo odio. Libero justo laoreet sit amet cursus sit amet. Scelerisque felis imperdiet proin fermentum leo. Erat nam at lectus urna duis convallis convallis tellus.\n\n"
+ " I – SÍNTESE DA DEMANDA\n\n"
+ " Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Tellus id interdum velit laoreet. Sapien faucibus et molestie ac feugiat sed lectus vestibulum. Suscipit adipiscing bibendum est ultricies integer quis auctor. Egestas fringilla phasellus faucibus scelerisque eleifend donec. Pharetra pharetra massa massa ultricies mi. Urna nunc id cursus metus aliquam. Faucibus a pellentesque sit amet porttitor eget dolor morbi non. Sapien pellentesque habitant morbi tristique senectus et netus. Tincidunt dui ut ornare lectus sit amet est placerat in. Est velit egestas dui id ornare. Dignissim enim sit amet venenatis urna cursus eget. Pellentesque habitant morbi tristique senectus et netus et malesuada. Orci dapibus ultrices in iaculis nunc sed augue lacus. Eu facilisis sed odio morbi quis commodo odio. Libero justo laoreet sit amet cursus sit amet. Scelerisque felis imperdiet proin fermentum leo. Erat nam at lectus urna duis convallis convallis tellus.\n\n"
+ " II – PRELIMINARMENTE\n\n"
+ "II.I – A PERDA SUPERVENIENTE DO INTERESSE PROCESSUAL\n\n"
+ "Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Tellus id interdum velit laoreet. Sapien faucibus et molestie ac feugiat sed lectus vestibulum. Suscipit adipiscing bibendum est ultricies integer quis auctor. Egestas fringilla phasellus faucibus scelerisque eleifend donec. Pharetra pharetra massa massa ultricies mi. Urna nunc id cursus metus aliquam. Faucibus a pellentesque sit amet porttitor eget dolor morbi non. Sapien pellentesque habitant morbi tristique senectus et netus. Tincidunt dui ut ornare lectus sit amet est placerat in. Est velit egestas dui id ornare. Dignissim enim sit amet venenatis urna cursus eget. Pellentesque habitant morbi tristique senectus et netus et malesuada. Orci dapibus ultrices in iaculis nunc sed augue lacus. Eu facilisis sed odio morbi quis commodo odio. Libero justo laoreet sit amet cursus sit amet. Scelerisque felis imperdiet proin fermentum leo. Erat nam at lectus urna duis convallis convallis tellus.\n\n"
+ "II.II - INVIABILIDADE DE CONCILIAÇÃO\n\n"
+ " Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Tellus id interdum velit laoreet. Sapien faucibus et molestie ac feugiat sed lectus vestibulum. Suscipit adipiscing bibendum est ultricies integer quis auctor. Egestas fringilla phasellus faucibus scelerisque eleifend donec. Pharetra pharetra massa massa ultricies mi. Urna nunc id cursus metus aliquam. Faucibus a pellentesque sit amet porttitor eget dolor morbi non. Sapien pellentesque habitant morbi tristique senectus et netus. Tincidunt dui ut ornare lectus sit amet est placerat in. Est velit egestas dui id ornare. Dignissim enim sit amet venenatis urna cursus eget. Pellentesque habitant morbi tristique senectus et netus et malesuada. Orci dapibus ultrices in iaculis nunc sed augue lacus. Eu facilisis sed odio morbi quis commodo odio. Libero justo laoreet sit amet cursus sit amet. Scelerisque felis imperdiet proin fermentum leo. Erat nam at lectus urna duis convallis convallis tellus.\n\n"
+ "II.III – DA INCORREÇÃO DO VALOR ATRIBUÍDO À CAUSA. ARTIGO 293\n"
+ "C/C ARTIGO 337, III, DO CÓDIGO DE PROCESSO CIVIL/2015\n\n"
+ " Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Tellus id interdum velit laoreet. Sapien faucibus et molestie ac feugiat sed lectus vestibulum. Suscipit adipiscing bibendum est ultricies integer quis auctor. Egestas fringilla phasellus faucibus scelerisque eleifend donec. Pharetra pharetra massa massa ultricies mi. Urna nunc id cursus metus aliquam. Faucibus a pellentesque sit amet porttitor eget dolor morbi non. Sapien pellentesque habitant morbi tristique senectus et netus. Tincidunt dui ut ornare lectus sit amet est placerat in. Est velit egestas dui id ornare. Dignissim enim sit amet venenatis urna cursus eget. Pellentesque habitant morbi tristique senectus et netus et malesuada. Orci dapibus ultrices in iaculis nunc sed augue lacus. Eu facilisis sed odio morbi quis commodo odio. Libero justo laoreet sit amet cursus sit amet. Scelerisque felis imperdiet proin fermentum leo. Erat nam at lectus urna duis convallis convallis tellus.\n\n"
+ " [1]\n"
+ "Fulano da silva :\n"
+ " “Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Tellus id interdum velit laoreet. Sapien faucibus et molestie ac feugiat sed lectus vestibulum. Suscipit adipiscing bibendum est ultricies integer quis auctor. Egestas fringilla phasellus faucibus scelerisque eleifend donec. Pharetra pharetra massa massa ultricies mi. Urna nunc id cursus metus aliquam. Faucibus a pellentesque sit amet porttitor eget dolor morbi non. Sapien pellentesque habitant morbi tristique senectus et netus. Tincidunt dui ut ornare lectus sit amet est placerat in. Est velit egestas dui id ornare. Dignissim enim sit amet venenatis urna cursus eget. Pellentesque habitant morbi tristique senectus et netus et malesuada. Orci dapibus ultrices in iaculis nunc sed augue lacus. Eu facilisis sed odio morbi quis commodo odio. Libero justo laoreet sit amet cursus sit amet. Scelerisque felis imperdiet proin fermentum leo. Erat nam at lectus urna duis convallis convallis tellus.”\n"
+ " (Grifamos)\n\n"
+ " [2]\n"
+ " Na mesma direção, leciona o professor Fulano :\n\n"
+ " “ Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Tellus id interdum velit laoreet. Sapien faucibus et molestie ac feugiat sed lectus vestibulum. Suscipit adipiscing bibendum est ultricies integer quis auctor. Egestas fringilla phasellus faucibus scelerisque eleifend donec. Pharetra pharetra massa massa ultricies mi. Urna nunc id cursus metus aliquam. Faucibus a pellentesque sit amet porttitor eget dolor morbi non. Sapien pellentesque habitant morbi tristique senectus et netus. Tincidunt dui ut ornare lectus sit amet est placerat in. Est velit egestas dui id ornare. Dignissim enim sit amet venenatis urna cursus eget. Pellentesque habitant morbi tristique senectus et netus et malesuada. Orci dapibus ultrices in iaculis nunc sed augue lacus. Eu facilisis sed odio morbi quis commodo odio. Libero justo laoreet sit amet cursus sit amet. Scelerisque felis imperdiet proin fermentum leo. Erat nam at lectus urna duis convallis convallis tellus..\n\n"
+ " Nesse sentido, segue a remansosa jurisprudência do Superior\n"
+ "Tribunal de Justiça (grifamos):\n\n"
+ " PROCESSUAL CIVIL. RECURSO ESPECIAL. HONORÁRIOS\n"
+ " ADVOCATÍCIOS. EQUIDADE. REEXAME DE FATOS E PROVAS.\n"
+ " IMPOSSIBILIDADE. 1. Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Tellus id interdum velit laoreet. Sapien faucibus et molestie ac feugiat sed lectus vestibulum. Suscipit adipiscing bibendum est ultricies integer quis auctor. Egestas fringilla phasellus faucibus scelerisque eleifend donec. Pharetra pharetra massa massa ultricies mi. Urna nunc id cursus metus aliquam. Faucibus a pellentesque sit amet porttitor eget dolor morbi non. Sapien pellentesque habitant morbi tristique senectus et netus. Tincidunt dui ut ornare lectus sit amet est placerat in. Est velit egestas dui id ornare. Dignissim enim sit amet venenatis urna cursus eget. Pellentesque habitant morbi tristique senectus et netus et malesuada. Orci dapibus ultrices in iaculis nunc sed augue lacus. Eu facilisis sed odio morbi quis commodo odio. Libero justo laoreet sit amet cursus sit amet. Scelerisque felis imperdiet proin fermentum leo. Erat nam at lectus urna duis convallis convallis tellus.\n\n"
+ " III – DO MÉRITO\n\n"
+ "III.I – DA NECESSIDADE DE RESPEITO À FILA DE ESPERA PARA\n"
+ "REALIZAÇÃO DE TRATAMENTO MÉDICO\n\n"
+ " Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Tellus id interdum velit laoreet. Sapien faucibus et molestie ac feugiat sed lectus vestibulum. Suscipit adipiscing bibendum est ultricies integer quis auctor. Egestas fringilla phasellus faucibus scelerisque eleifend donec. Pharetra pharetra massa massa ultricies mi. Urna nunc id cursus metus aliquam. Faucibus a pellentesque sit amet porttitor eget dolor morbi non. Sapien pellentesque habitant morbi tristique senectus et netus. Tincidunt dui ut ornare lectus sit amet est placerat in. Est velit egestas dui id ornare. Dignissim enim sit amet venenatis urna cursus eget. Pellentesque habitant morbi tristique senectus et netus et malesuada. Orci dapibus ultrices in iaculis nunc sed augue lacus. Eu facilisis sed odio morbi quis commodo odio. Libero justo laoreet sit amet cursus sit amet. Scelerisque felis imperdiet proin fermentum leo. Erat nam at lectus urna duis convallis convallis tellus.:\n\n"
+ " “AGRAVO DE INSTRUMENTO. AÇÃO DE OBRIGAÇÃO DE\n"
+ " FAZER. FORNECIMENTO DE MEDICAMENTOS.\n"
+ " INDEFERIMENTO DA TUTELA ANTECIPADA COM\n"
+ " RELAÇÃO AO FÁRMACO XPTO, SOB O\n"
+ " FUNDAMENTO DE NÃO SER RECOMENDADO PELO\n"
+ " CONSELHO NACIONAL DE MEDICINA. DEFERIMENTO\n"
+ " PARCIAL DA TUTELA PARA A REALIZAÇÃO DE\n"
+ " CIRURGIA DE CATARATA. FILA DE ESPERA PARA\n"
+ " INTERVENÇÃO CIRÚRGICA. SITUAÇÃO COMUM A\n"
+ " DIVERSOS CIDADÃOS.\n"
+ " (...)\n\n"
+ " Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Tellus id interdum velit laoreet. Sapien faucibus et molestie ac feugiat sed lectus vestibulum. Suscipit adipiscing bibendum est ultricies integer quis auctor. Egestas fringilla phasellus faucibus scelerisque eleifend donec. Pharetra pharetra massa massa ultricies mi. Urna nunc id cursus metus aliquam. Faucibus a pellentesque sit amet porttitor eget dolor morbi non. Sapien pellentesque habitant morbi tristique senectus et netus. Tincidunt dui ut ornare lectus sit amet est placerat in. Est velit egestas dui id ornare. Dignissim enim sit amet venenatis urna cursus eget. Pellentesque habitant morbi tristique senectus et netus et malesuada. Orci dapibus ultrices in iaculis nunc sed augue lacus. Eu facilisis sed odio morbi quis commodo odio. Libero justo laoreet sit amet cursus sit amet. Scelerisque felis imperdiet proin fermentum leo. Erat nam at lectus urna duis convallis convallis tellus.”\n\n"
+ " ADMINISTRATIVO. FILA DE ESPERA PARA CIRURGIA.\n"
+ " PRINCÍPIO DA ISONOMIA. 1. A fila de espera para\n"
+ " cirurgia é estabelecida de forma isonômica e\n"
+ " impessoal, de modo a atender à necessidade\n"
+ " de todos. 2. Sem demonstração de ilegitimidade\n"
+ " da fila e, pois, da ilegalidade ou abuso de poder (art.\n"
+ " 5º, LXIX, CF), qualquer decisão judicial que\n"
+ " determine cirurgia imediata caracterizaria\n"
+ " injustificada vantagem pessoal à vista da situação\n"
+ " comum em que se encontram os vários pacientes\n"
+ " na fila. Precedentes (TRF da 2ª Região: AG nº 167.827,\n"
+ " AG nº 2010.02.01.016779-2, AG nº 172.689, AG nº\n"
+ " 178.070).\n\n"
+ " (...)\n\n\n"
+ " IV – CONCLUSÃO\n\n"
+ " Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Tellus id interdum velit laoreet. Sapien faucibus et molestie ac feugiat sed lectus vestibulum. Suscipit adipiscing bibendum est ultricies integer quis auctor. Egestas fringilla phasellus faucibus scelerisque eleifend donec. Pharetra pharetra massa massa ultricies mi. Urna nunc id cursus metus aliquam. Faucibus a pellentesque sit amet porttitor eget dolor morbi non. Sapien pellentesque habitant morbi tristique senectus et netus. Tincidunt dui ut ornare lectus sit amet est placerat in. Est velit egestas dui id ornare. Dignissim enim sit amet venenatis urna cursus eget. Pellentesque habitant morbi tristique senectus et netus et malesuada. Orci dapibus ultrices in iaculis nunc sed augue lacus. Eu facilisis sed odio morbi quis commodo odio. Libero justo laoreet sit amet cursus sit amet. Scelerisque felis imperdiet proin fermentum leo. Erat nam at lectus urna duis convallis convallis tellus.\n\n"
+ " Rio de Janeiro, 15 de dezembro de 2022.\n\n"
+ " Fulano da Silva\n"
+ " Procurador do Estado";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}