$re = '/^[^\s;]+@[^\s;]+\.[^\s;]+(?:;[^\s;]+@[^\s;]+\.[^\s;]+)*$/m';
$str = 'example1@email.com
example1@email.com;example2@email.com;example3@email.com;example4@email.com
example1@email.com;example2email.com;example3@email.com;
example1@email.com;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);