using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(0?[1-9]|[12][0-9]|3[01])\/(0?[1-9]|1[012])\/\d{4}";
string input = @"2020
2019/10/16
2020/08/12
31/01/2020
2020-11-03
05/01/2020
04/17/2020
2019/12/31
2021-07-14
2019/12/04
2010/12/16
2021
04/03/2020
4/30/2020
2011/07/18
2017/06/20
2019
2021-10-13
2020
2021-07-14
2021/11/08
2020-11-03
2021
2019/12/31
2019-12-04
null
2020/01/04";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}