use strict;
my $str = '43.167.0.255
43.167.0.255.
023.123.123.123
002.00.055.255';
my $regex = qr/^(([01]?\d?\d|2[0-4]\d|25[0-5])(\.(?!$)|$)){4}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}