$re = '/^(?:(?!Word1|Word2|Word3)[\s\S])+$/m';
$str = 'foo bar Word1 baz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);