package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)`\S{1,}``)
var str = `Here is a sample text having references to code items.
Say it is a markdown file for instance holding a documentation.
I may talk about how the \`MyMethod()\` function returns an
instance of \`MyObject\` that is helpful \`\`
in solving my problem.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}