re = /^function/m
str = 'function abc(a,b,c,...) {
function xyz(a,b,c,...) {
....
}
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end