$re = '/^(?!.*(RedGemEtc)).*(?(1)xyzzy|<.>)/m';
$str = 'a baz blahblah foobar <紅> a
b baz RedGemEtc foobar <黑> b
c baz blahblah foobar <不> c
d baz RedGemEtc foobar [巴] d
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);