# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<style>([\s\S]*)</style>"
test_str = ("<!DOCTYPE html>\n"
"<html>\n"
" <head>\n"
" <style>\n"
" body {background-color: powderblue;}\n"
" h1 {color: blue;}\n"
" p {color: red;}\n"
" </style>\n"
" </head>\n\n"
" <body>\n\n"
" <h1>This is a heading</h1>\n"
" <p>This is a paragraph.</p>\n\n"
" </body>\n"
"</html>")
subst = " "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.