re = /(?:^|___|[+(])([a-zA-Z0-9]{2,})(?=$|___|[+)])/m
str = '___file___name___2000___ed2___1___2___3
DIFFERENT+FILENAME+(2000)+1+2+3+ed10'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end