$re = '/\'[^\']*\'(*SKIP)(*F)|\b[_A-Za-z]\w*\b(?![(\'])/';
$str = '12+x1+455+\'ggg+4+rrr+tt\'+3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);