$re = '/^(\[Kick: \w+\] )?!charity/m';
$str = '[Kick: TheShiningOne] !charity
[Kick: dasdasd] !charity
!charity
!char';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);