package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<errorCode>ERROR\s\[[^\]]+\])`)
var str = `ERROR [43f796d8da]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}