const regex = /(?:\G(?!^)\",|\"Name\":\[)\"\K[^\"\\]*(?:\\.[^\"\\]*)*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G(?!^)\\",|\\"Name\\":\\[)\\"\\K[^\\"\\\\]*(?:\\\\.[^\\"\\\\]*)*', 'gm')
const str = `{"Name":["Jobs","Kill \\"Bill\\""]}`;
const subst = `******`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);