#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[1-9]{1}[0-9]?([\.]?[0-9]+|[0-9]*)[GT]{1}$"
Local $sString = "10.8G" & @CRLF & _
"5G" & @CRLF & _
"1.5G" & @CRLF & _
"15G" & @CRLF & _
"0" & @CRLF & _
"5" & @CRLF & _
"0.5" & @CRLF & _
"G" & @CRLF & _
".G" & @CRLF & _
".5G" & @CRLF & _
"1.G"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")