$re = '/\bK\[Al\(OH\)4\](?=\s|\b)/i';
$str = 'NH3 + K[Al(OH)4] + NaCl';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);