re = /OUT: (?<method>.*?) - time taken: (?<executiontime>\d+) ms/m
str = '{ "event" : "test", "message" : "OUT: IndexController.printHello - time taken: 519 ms"}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end