$re = '/^0(?=(?:(?:[^1]*1){2})+[^1]*0$).*/';
$str = '01010
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);