import Foundation
let pattern = #"(?<!^|[A-Z\p{P}])[A-Z]|(?<=\p{P})\p{P}|(?<=[a-z])(?=\d)|(?<=\d)(?=[a-z])|(?<=[A-Z])(?=\d)|(?<=\d)(?=[A-Z])|(((?<!^)[A-Z](?=[a-z]))|((?<=[a-z])[A-Z]))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"ThisIsAnExample.TitleHELLO-WORLD2019T.E.S.T.(Test)"Test"'Test'[Test]. OTPIsADevice"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" $0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)