re = /^[\w \,\.]*(Charge Tip)[\w \,\.]*(\-V)[\w \,\.]*$/m
str = 'Lorem ipsum dolor sit -V amet, consectetuer adipiscing elit.
Aenean commodo ligula Charge Tip eget dolor. Aenean massa.
Cum sociis natoque penatibus et magnis dis parturient montes.
Nascetur ridiculus Charge Tip mus. Donec quam felis,-Vultricies nec.
Pellentesque eu, pretium quis, sem. Nulla consequat massa.
Quis enim. DonecCharge Tippede justo, fringilla vel, aliquet nec.-V
Vulputate eget, arcu. In enim justo, rhoncus ut.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end