$re = '/([^\s()]+\([^()]*\))|(\([^()]*\)[^\s()]+)|[()]/m';
$str = 'abc (xyz pqr) qwe ew (kjlk asd) ue(aad) kljl (aad)ue ue(aad)ue(aad)ue(aad)(aad)ueue(aad)(aad)(aad) (aad) (aad) (aad) a(aad)q(aad)(aad)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);