package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https?://[^/]*\.([^/]+)`)
var str = `https://www.google.pl`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}