$re = '/\[\w*\s(bar)\s\w+\]/';
$str = '[foo bar monkey] foo bar monkey';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);