$re = '/([^\\\\]+)\.pro\\\\$/m';
$str = '\\\\NH-Data\\Public\\CAD\\Projekte\\UV_A_1_GL402.pro\\
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);