$re = '/[KGQ]u?add?aff?[iy]/m';
$str = 'Kadafi
Quaddafi
Gadaffy';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);