re = /\[([^\]\[=]*)==([^\]\[=]*)\]/m
str = '[type==STRING]
[type==STRING][amount==0]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end