// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^v(0|[1-9]\d*)\.(0|[1-9]\d*)\.(0|[1-9]\d*)(?:-((?:0|[1-9]\d*|\d*[a-zA-Z-][0-9a-zA-Z-]*)(?:\.(?:0|[1-9]\d*|\d*[a-zA-Z-][0-9a-zA-Z-]*))*))(?:\+([0-9a-zA-Z-]+(?:\.[0-9a-zA-Z-]+)*))?$").unwrap();
let string = "Full Semantic Versions RegEx: https://regex101.com/r/vkijKf/1/
# Valid Release Semantic Versions
v0.0.4
v1.2.3
v10.20.30
v1.1.2+meta
v1.1.2+meta-valid
v1.0.0
v2.0.0
v1.1.7
v2.0.0+build.1848
v1.0.0+0.build.1-rc.10000aaa-kk-0.1
v99999999999999999999999.999999999999999999.99999999999999999
# Valid Pre-release Semantic Versions
v1.1.2-prerelease+meta
v1.0.0-alpha
v1.0.0-beta
v1.0.0-alpha.beta
v1.0.0-alpha.beta.1
v1.0.0-alpha.1
v1.0.0-alpha0.valid
v1.0.0-alpha.0valid
v1.0.0-alpha-a.b-c-somethinglong+build.1-aef.1-its-okay
v1.0.0-rc.1+build.1
v2.0.0-rc.1+build.123
v1.2.3-beta
v10.2.3-DEV-SNAPSHOT
v1.2.3-SNAPSHOT-123
v2.0.1-alpha.1227
v1.0.0-alpha+beta
v1.2.3----RC-SNAPSHOT.12.9.1--.12+788
v1.2.3----R-S.12.9.1--.12+meta
v1.2.3----RC-SNAPSHOT.12.9.1--.12
v1.0.0-0A.is.legal
# Invalid Semantic Versions
1
1.2
1.2.3-0123
1.2.3-0123.0123
1.1.2+.123
+invalid
-invalid
-invalid+invalid
-invalid.01
alpha
alpha.beta
alpha.beta.1
alpha.1
alpha+beta
alpha_beta
alpha.
alpha..
beta
1.0.0-alpha_beta
-alpha.
1.0.0-alpha..
1.0.0-alpha..1
1.0.0-alpha...1
1.0.0-alpha....1
1.0.0-alpha.....1
1.0.0-alpha......1
1.0.0-alpha.......1
01.1.1
1.01.1
1.1.01
1.2
1.2.3.DEV
1.2-SNAPSHOT
1.2.31.2.3----RC-SNAPSHOT.12.09.1--..12+788
1.2-RC-SNAPSHOT
-1.0.3-gamma+b7718
+justmeta
9.8.7+meta+meta
9.8.7-whatever+meta+meta
99999999999999999999999.999999999999999999.99999999999999999----RC-SNAPSHOT.12.09.1--------------------------------..12";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}