$re = '/(something)(\d)\2/';
$str = 'something2
something22
something23';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);