$re = '/^[1-9]\d{2}[-][1-9]\d{2}[-]\d{4}$/';
$str = '504-393-9727';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);