import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(?!\\/?(?:li|ul|a)\\b)\\/?[^>]+(?:>|$)";
final String string = "<a href=\"ddd\">eee</a><p> some text </p> and <li>text</li> <li/> <a/> <a />\n"
+ "<ul> </ul>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}