import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?=.*[a])(?:(?=.*[b])(?=.*(?:[c]|[d]|[e]))|(?=.*[c])(?=.*(?:[d]|[e])))|(?=.*[d])(?=.*[e])|(?=.*[b])(?:(?=.*[c])(?=.*[d])|(?=.*([c]|[d]))(?=.*[e]))|(?=.*[c])(?=.*[d])(?=.*[e])).*$";
final String string = "abcde\n"
+ "edcba\n"
+ "cbdae\n"
+ "bdeac\n"
+ "aaabbb\n\n\n"
+ "abc\n"
+ "abd\n"
+ "abe\n"
+ "acd\n"
+ "ace\n"
+ "ade\n"
+ "bcd\n"
+ "bce\n"
+ "bde\n"
+ "cde\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}