$re = '/(\^\d)([^\^]+)/m';
$str = '^4Re^5fresh^11-PUG';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);