$re = '/[^\.]+\.[^\.]+$/';
$str = 'long-server-name.google-name.SomeLongTDL';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);