$re = '/^[0-9.\s\-]+/m';
$str = '01. A little love (2002)
02 - No.1 Star
03 Love Story';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);