// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)^t(\w*) (?:changelog|chlog|chglog) (\w*)(?:\(([\w\$\.\-\*\sа-яА-Я]*)\))?\:\s(.*)$").unwrap();
let string = "t222 changelog add(Специалист): Добавлена какая-то херабора";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}