#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([\s]{2,})(?!.*[&@])(.*?)([,{])\n"
Local $sString = "#term-header {" & @CRLF & _
" padding: 20px 0 17px;" & @CRLF & _
" margin: 0 10px 30px;" & @CRLF & _
" &::before," & @CRLF & _
" &::after {" & @CRLF & _
" margin-left: -11px;" & @CRLF & _
" border-width: 12px 10.5px 0 10.5px;" & @CRLF & _
" }" & @CRLF & _
" &::before {" & @CRLF & _
" bottom: -12px;" & @CRLF & _
" }" & @CRLF & _
" &::after {" & @CRLF & _
" bottom: -10px;" & @CRLF & _
" }" & @CRLF & _
" h1 {" & @CRLF & _
" font-size: 20px;" & @CRLF & _
" span {" & @CRLF & _
" font-size: 27px;" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" dl {" & @CRLF & _
" margin: 20px 0 0;" & @CRLF & _
" dt {" & @CRLF & _
" width: 100px;" & @CRLF & _
" }" & @CRLF & _
" dd {" & @CRLF & _
" font-size: 11px;" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
".slick-next," & @CRLF & _
".slick-prev {" & @CRLF & _
" width: 35px;" & @CRLF & _
" height: 35px;" & @CRLF & _
"}" & @CRLF & _
".slick-prev {" & @CRLF & _
" left: 5px;" & @CRLF & _
" transform: translate3d(-30px, 0, 0);" & @CRLF & _
" &::after {" & @CRLF & _
" left: 14px;" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
".slick-next {" & @CRLF & _
" right: 5px;" & @CRLF & _
" transform: translate3d(30px, 0, 0);" & @CRLF & _
" &::after {" & @CRLF & _
" right: 14px;" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
".ready.inview {" & @CRLF & _
" .slick-prev {" & @CRLF & _
" &.slick-disabled {" & @CRLF & _
" transform: translate3d(-30px, 0, 0);" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" .slick-next {" & @CRLF & _
" &.slick-disabled {" & @CRLF & _
" transform: translate3d(30px, 0, 0);" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
".wp-editor {" & @CRLF & _
" font-family: var(--fontFamily);" & @CRLF & _
" font-size: var(--fontSize);" & @CRLF & _
" line-height: var(--lineHeight);" & @CRLF & _
" & h3," & @CRLF & _
" & h4," & @CRLF & _
" & p {" & @CRLF & _
" margin: var(--wpEditorMargin) 0;" & @CRLF & _
" overflow: hidden;" & @CRLF & _
" &:first-child {" & @CRLF & _
" margin-top: 0;" & @CRLF & _
" }" & @CRLF & _
" &:last-child {" & @CRLF & _
" margin-bottom: 0;" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" & h3 {" & @CRLF & _
" font-size: 14px;" & @CRLF & _
" }" & @CRLF & _
" & h4 {" & @CRLF & _
" font-size: 13px;" & @CRLF & _
" }" & @CRLF & _
" & a {" & @CRLF & _
" color: var(--linkColor);" & @CRLF & _
" text-decoration: underline;" & @CRLF & _
" &:hover {" & @CRLF & _
" text-decoration: none;" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" & img {" & @CRLF & _
" max-width: 100%;" & @CRLF & _
" height: auto;" & @CRLF & _
" }" & @CRLF & _
" & blockquote {" & @CRLF & _
" padding-left: 15px;" & @CRLF & _
" margin: var(--wpEditorMargin) 0;" & @CRLF & _
" font-weight: bold;" & @CRLF & _
" border-left: 5px solid var(--borderColor);" & @CRLF & _
" @media (--viewport-medium) {" & @CRLF & _
" padding-left: 35px;" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")