import re
regex = re.compile(r"(sierra-cp|sierracp|sierra-cpengineering|sierracpengineering|sierracpeng|sierraemissions)(\.net|\.com|\.org|\.us|\.cn)\/?(([a-zA-Z0-9_\-\.]+\/?){0,})")
test_str = "sierra-cp.com/cat/eat"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")