package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\/]+[0-9]{1,}`)
var str = `/nazvanie-stranica789
/page/2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}