package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)£[^#£@]*(#.[^#£@]*)*@`)
var str = `fasdf asd£dfafsdafasdfasd## fdasdf #@ fdas #£ fdafasdsfd@ fasdfasd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}