package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\&(amp;)?`)
var str = `Two + Two & One + One ?
Two + Two & One + One ?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}