#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^(?:" & @CRLF & _
"(?:0[1-9]|1\d|2[0-8])([\/-])(?:02)\1(?:\d+)|" & @CRLF & _
"(?:0[1-9]|1\d|2\d)([\/-])(?:02)\2(?:(?:\d*?(?:(?:0[48]|[13579][26]|[2468][048])|(?:(?:[02468][048]|[13579][26])00))|[48]00|[48])(?=\D|\b))|" & @CRLF & _
"(?:0[1-9]|1\d|2\d|30)([\/-])(?:0[469]|11)\3(?:\d+)|" & @CRLF & _
"(?:0[1-9]|1\d|2\d|3[01])([\/-])(?:0[13578]|1[02])\4(?:\d+)|" & @CRLF & _
"(?:02)([\/-])(?:0[1-9]|1\d|2[0-8])\5(?:\d+)|" & @CRLF & _
"(?:02)([\/-])(?:0[1-9]|1\d|2\d)\6(?:(?:\d*?(?:(?:0[48]|[13579][26]|[2468][048])|(?:(?:[02468][048]|[13579][26])00))|[48]00|[48])(?=\D|\b))|" & @CRLF & _
"(?:0[469]|11)([\/-])(?:0[1-9]|1\d|2\d|30)\7(?:\d+)|" & @CRLF & _
"(?:0[13578]|1[02])([\/-])(?:0[1-9]|1\d|2\d|3[01])\8(?:\d+)|" & @CRLF & _
"(?:\d+)([\/-])(?:0[1-9]|1\d|2[0-8])\9(?:02)|" & @CRLF & _
"(?:(?:\d*?(?:(?:0[48]|[13579][26]|[2468][048])|(?:(?:[02468][048]|[13579][26])00))|[48]00|[48])(?=\D|\b))([\/-])(?:0[1-9]|1\d|2\d)\10(?:02)|" & @CRLF & _
"(?:\d+)([\/-])(?:0[1-9]|1\d|2\d|30)\11(?:0[469]|11)|" & @CRLF & _
"(?:\d+)([\/-])(?:0[1-9]|1\d|2\d|3[01])\12(?:0[13578]|1[02])|" & @CRLF & _
"(?:\d+)([\/-])(?:02)\13(?:0[1-9]|1\d|2[0-8])|" & @CRLF & _
"(?:(?:\d*?(?:(?:0[48]|[13579][26]|[2468][048])|(?:(?:[02468][048]|[13579][26])00))|[48]00|[48])(?=\D|\b))([\/-])(?:02)\14(?:0[1-9]|1\d|2\d)|" & @CRLF & _
"(?:\d+)([\/-])\15(?:0[469]|11)(?:0[1-9]|1\d|2\d|30)|" & @CRLF & _
"(?:\d+)([\/-])(?:0[13578]|1[02])\16(?:0[1-9]|1\d|2\d|3[01])" & @CRLF & _
")$"
Local $sString = "30/11/2017" & @CRLF & _
"30-11-2017" & @CRLF & _
"2017-05-31" & @CRLF & _
"" & @CRLF & _
"30-/11-/2017" & @CRLF & _
"30-11/2017"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")