using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(\d{5}-\d{4})\b|-";
string substitution = @"\1 ";
string input = @"12345-4567 hello-you 45-year N-45";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}