package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\+(?:(?:\d{11})?(?:\d\(\d{3}\))?(?:(?:\d{7})?(?:-\d{3}-\d{4})?))$`)
var str = `+19999999999
+1(999)9999999
+1(999)-999-9999`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}