$re = '/(\d{4}-\d\d-\d\d(?!.*\d{4}-\d\d-\d\d))/m';
$str = '"http://www.google.com/search","XYZ","Some other Value","2018-04-09","false","2017-12-13"
"http://www.google.com/search","XYZ","Some other Value","2018-12-09","false","false"
"http://www.google.com/search","XYZ","Some other Value","false","2000-09-17","false"
"http://www.google.com/search","XYZ","Some other Value","2018-12-09","2000-09-17","2017-12-13"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);