$re = '/\b(\w+)-+(?!\1\b)\w+/m';
$str = 'matches: hey-hey
not matches: hey-hei';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);