re = /^(?!.*\[!)[^]\n]*]/m
str = '_dynamic_text_[!_dynamic_text_]_dynamic_text_
_dynamic_text__dynamic_text_]_dynamic_text_'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end