// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)M\D*[\d\.]+\s*[a-zA-Z]*\s*[\d\.]+").unwrap();
let string = "M > 10
M > 1
M < 10
M < 1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}