$re = '/[,.](?=[^,.\r\n]*$)/m';
$str = 'this is a, test , test . test , test .t test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);