$re = '/(.*?(Fab)){3}/m';
$str = 'Fab1 Fab2 Fab3
Fab1 Fab2 Fab3 Fab4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);