import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "!\\n(interesting1 (?P<a>.*?)$.*?(?:interesting2 (?P<c>.*?))?$\\n(?=!))";
final String string = "!\n"
+ "interesting1 a\n"
+ "not interesting b\n"
+ "interesting2 c\n"
+ "!\n"
+ "interesting1 a\n"
+ "not interesting b\n"
+ "interesting2 c\n"
+ "!\n"
+ "interesting1 a\n"
+ "not interesting b\n"
+ "interesting2 c\n"
+ "not interesting d\n"
+ "!";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}